Help us make Mixer better for everyone.

Setting Background Image of button via c++ isn't working

Setting the background image of a button is not changing the button. Should I need to do anything else 3esides calling the method?
auto result = ::interactive_control_set_property_string(_session, "Image1", "backgroundImage", "https://...");

Here is the debug trace : the result is MIXER_OK

Queueing method: {"id":7,"method":"updateControls","discard":true,"seq":10,"params":{"sceneID":"default","controls":[{"controlID":"Image1","backgroundImage":"https://tse3.mm.bing.net/th?id=OIP.6RGX1DlxvqSevMPOWizDSAHaJ6&pid=Api"}]}}
Sending websocket message: {"id":7,"method":"updateControls","discard":true,"seq":10,"params":{"sceneID":"default","controls":[{"controlID":"Image1","backgroundImage":"https://tse3.mm.bing.net/th?id=OIP.6RGX1DlxvqSevMPOWizDSAHaJ6&pid=Api"}]}}
Websocket message received: {"type":"method","method":"onControlUpdate","params":{"sceneID":"default","controls":[{"controlID":"Image1","kind":"button","etag":"","disabled":false,"cooldown":0,"cost":0,"backgroundColor":"#240be2","borderColor":"#f73e3e","meta":{},"position":[{"size":"large","width":17,"height":10,"x":25,"y":6}],"text":"Image1","backgroundImage":"https://tse3.mm.bing.net/th?id=OIP.6RGX1DlxvqSevMPOWizDSAHaJ6&pid=Api"}]},"id":0,"seq":12,"discard":true}

Any suggestions?

1 vote
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Michael S. Scherotter shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

0 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...

Feedback and Knowledge Base